Outbound calling trouble
Incident Report for Masiero
Resolved
The impacted upstream carrier has resolved today's earlier outbound calling issue. If any further trouble with outbound dialing, please email call examples to team@masiero.tech for further evaluation. Thank you for your patience.
Posted Mar 16, 2020 - 20:56 UTC
Monitoring
We have identified and re-routed for trouble placing outbound calls to select numbers. More updates as they become available.
Posted Mar 16, 2020 - 18:56 UTC
This incident affected: Masiero Voice.