Inbound toll free call failures
Incident Report for Masiero
Resolved
We have continued to monitor and confirm we have had no new reported incidents with regards to inbound call failures to Masiero Toll Free DIDs since Verizon was removed from routes.

At this point the relevant teams are still engaging on finding a solution to the intermittent nature of receiving calls with Verizon. Until such a time, Verizon will continue to stay removed from route and we assure our customers that we've a plan in place to minimize and resolve any such potential future occurrences. We sincerely apologize for any inconvenience caused and thank our customers for their continued patience.
Posted Jul 03, 2018 - 23:00 UTC
Identified
We identified that Verizon has been having intermittent issues originating calls into Masiero Toll Free Phone Numbers.

We have completely removed them from route but any other customers that rely on Verizon for originating calls into their Toll Free DID's will still see intermittent issues until Verizon resolves the issue.

Masiero Engineers are still engaging with Verizon at this point and we will continue to provide updates. We thank you for your continued patience.
Posted Jul 03, 2018 - 20:27 UTC
Investigating
We are investigating an issue where inbound calls to toll free numbers are not reaching the Masiero Network. The issue started Jul 3, 2018 2:36 PM EDT and has been intermittent since. We are continuing to investigate upstream from Masiero with multiple carriers to determine why calls are failing route.
Posted Jul 03, 2018 - 19:52 UTC