Weather related Spectrum Internet outages
Incident Report for Masiero
Resolved
We continue to see normalization in Spectrum Internet Connections throughout the Hudson Valley, NY region. We understand the importance of a quality Internet Connection to our clients and take widespread carrier issues as such seriously. If any further trouble or to learn more about ways to help avoid such outages in the future via dedicated fiber or redundant Internet options, please email team@masierotechgroup.com.
Posted Mar 02, 2018 - 22:02 UTC
Update
As of 3:32pm, we are beginning to see stability return across Spectrum Connections. Please be aware other outages today are likely given the winter storm. Our network operations team is continuing to monitor this outage and will provide updates accordingly.

Spectrum's regional network operations (Middletown, NY) provided the following update at 3:20pm... "All outages are related to power, not sure when Central Hudson or Orange & Rockland will restore."
Posted Mar 02, 2018 - 20:38 UTC
Update
At approximately 2:35pm EST, we seeing a resurgence of widespread service interruptions with customers serviced by Spectrum Internet throughout the Hudson Valley, NY. This issue is occuring as of 2:58pm EST. Other fiber based networks such as Fios and Lightower/CrownCastle are not experiencing this issue. Our engineers are working with Spectrum to understand more about the severity of the issue. Another update to follow in 30 minutes.
Posted Mar 02, 2018 - 19:59 UTC
Monitoring
Masiero Network monitoring is charting multiple outages across Hudson Valley, NY this morning (9:20am to 9:25am and 11:12am to 11:23am EST) for clients on Internet delivered by Spectrum. We suspect these issues to be weather related. Connectivity appears restored at this time. Be aware that additional outages today are possible. Our team is continuing to monitor and will provide additional updates as they become available. For any additional questions, please email team@masierotechgroup.com.
Posted Mar 02, 2018 - 16:35 UTC